20/10/2017
Windev et les Api WindowsNb de visiteurs en ligne : 25
>> Introduction << >> Codes et Forum << >> Download <<


Nombre de messages : 24 page : 3 sur 3Première PagePage Précédente
Rubrique : 2 - Windev 7x       Sujet : Toujours à propos de Activex du navigateur I.Explorer
Auteur Message
 jcmskip Posté le : 29/01/2007 11:49:01


Bonjour,

J'ai un peu tout essayé champ HTML/ActiveX/Pilotage d'IE et j'ai toujours le même genre d'erreurs, il ne reconnait pas le membre document de l'objet automation...
Config : XP, WD9 + IE7
Quelqu'un a une idée ?

Merci

Jean-Christophe

 MC Posté le : 19/04/2007 17:59:57


Bonjour à tous,
j'ai un problème concernant l'activex du navigateur qui commence à me prendre la tête depuis plus d'une semaine.

J'ai créé un projet en WINDEV10 pour afficher un site internet et remplir certains champs de formulaire en automatique.
A l'ouverture de se site, il me demande un identifiant et un mot de passe pour ouvrir une session, jusqu'ici pas de problème mais certains lien ouvre une nouvelle fenetre mais cette fois ci il s'agit d'une fenetre d'InternetExplorer, il ne reconnait pas la session ouverte et me redemande de m'identifier.

Quelqu'un a t'il une idée ??? Peut on attribuer l'id de session ouvert par mon activeX au navigateur Internet Explorer pour qu'il évite de me demander la saisie du login et mot de passe.

NOTA : j'ai essayé d'utiliser l'évenement SetWindowsHookExA pour ne pas ouvrir la fenetre dans IE mais le site est dynamique et ne déclenche pas l'événement.

Merci d'avance

 Youenn Posté le : 15/11/2007 20:21:24


Bonjour,
La solution a ce problème serait d'utilier les événements NewWindow2 ou NewWindows3 de l'ActiveX IE. Malheureusement je n'arrive pas à l'utiliser en Windev.

Dans une des fenêtres de mon projet, j'ai 2 champs ActiveX WebBrowser. Je pilote mon premier champ par programmation mais parfois certains liens ouvrent IE . Je veux donc intercepter cette ouverture pour rediriger la nouvelle page dans mon second champ ActiveX WebBrowsser. Malheureusement je cherche depuis 1 an et je n'y arrive pas. Je ne peux pas non plus utiliser la procédure de hook proposée car mon application "navigue toute seule" et la souris n'est pas utilisée.

Les événements sont bien lancés mais je ne sais pas affecter l'ouverture à mon second champ.

Quelqu'un aurait-il déjà utilisé ces événements et réussi à les faire fonctionner.

Merci d'avance

 Tartuf Posté le : 01/01/2008 15:14:57


j'ai déjà vu ça en vb mais je n'ai plus l'exemple, tu pourras facilement trouver sur google

Nombre de messages : 24 page : 3 sur 3Première PagePage Précédente
>> Poster un message dans un NOUVEAU sujet.
>> Poster un message dans ce sujet.